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¢Ƙƛǎ ƳƻƴǘƘΩǎ ǳǇŘŀǘŜ introduces a ground-

ōǊŜŀƪƛƴƎ ƴŜǿ ŀŘŘƛǘƛƻƴ ǘƻ {hb!wΩǎ ¦ƴƛǾŜǊǎŀƭ 

Routing Technology: Patch Points. Now you 

Ŏŀƴ ŎǊŜŀǘŜΣ ƴŀƳŜΣ ŀƴŘ ŘŜƭŜǘŜ άtŀǘŎƘ tƻƛƴǘǎέ 

for bus and track I/O, and interconnect them 

for functions like track-to-track recording, bus-to-track recording, submixing, and much more. 

hŦ ŎƻǳǊǎŜ ǘƘŀǘΩǎ ƴƻǘ ŀƭƭτthere are major performance optimizations that affect all SONAR users 

(especially those who use lots of virtual instruments), upsample on playback, and more. So we 

ǿƻƴΩǘ ƪŜŜǇ ȅƻǳτgo make some great music. ς Bill Jackson and the Cakewalk Team 

 

 

Patch Points: This fulfills the other half of the promise of synth recordingτsend 

just about anything to anywhere, and record it all in a track. Whether you want to 

patch a track output to a track input, a bus or send output to a track, or record 

effects in real time, Patch Points can do all of these functionsτand much more. 

 

Aux Track: The Aux Track is a new track type that complements Patch Points. You 

can specify an Aux Track as a Patch Point, then feed a combination of multiple 

tracks, buses, or sends into it. The Aux Track is an ideal destination for summing, 

submixing, organizing, and controlling multiple tracks. 

 

Patch Point and Aux Track Applications: Now that you have this functionality, 

what are you going to do with it? This section covers several ways to use Patch 

Points and Aux Tracks, from multiband processing, to parallel processing, to ways 

to create different types of workflows. 

 

Start Screen Enhancements: Performance has been greatly improved; the Start 

Screen now appears immediately after SONAR loads or you call it up from the File 

menu. The Start Screen also appears more selectively, and various language 

incompatibility issues have been addressed.  

 

Upsample on Playback: As an extension to {hb!wΩǎ innovative upsampling 

technology, Upsample on Playback allows hearing upsampled plug-ins in real time 

during playback. Preview, compare, and process your audio with this new addition 

ǘƻ {hb!wΩǎ ŀǳŘƛƻ ŜƴƎƛƴŜΦ  

 



3 | P a g e 
 

Performance Optimizations: Load times, virtual instrument streaming, transport 

play/stop speed, VST scanning, pre-roll code, and CPU power savingsτ{hb!wΩǎ 

code has been stripped down and rebuilt for greater speed and smoother 

operation in several crucial areas. 

 

Workflow Enhancements and Fixes: In addition to the Start Screen 

enhancements, this update offers multiple fixes including another Staff View fix, 

VX-64/PX-64/Channel Tools updates that solve the audio pop issues that could 

sometimes occur, and fixes for a variety of intermittent issues. 

 

Review | Electronic Dance Music Grooves: Want to get into EDM, or fill {hb!wΩǎ 

step sequencer with some cool grooves? This book covers the process of creating 

beats with drums, gives plenty of examples, and includes a download code for 

hundreds of drum samples and MIDI files.  

 

Anatomy of a SONAR ProjectτReplacing the Placeholder: /ŀƪŜǿŀƭƪΩǎ WƛƳƳȅ 

Landry recently finished working on an award-winning indie movie. How he used 

SONARτas well as the process of how to create something that keeps the director 

and producer happyτmakes for a very interesting story. 

 

BlogBeat: ! ǊƻǳƴŘǳǇ ƻŦ ŀ ŦŜǿ ƻŦ ǘƘŜ /ŀƪŜǿŀƭƪ .ƭƻƎΩǎ άƎǊŜŀǘŜǎǘ ƘƛǘǎΦέ Find out the 

άwrongέ way to use the Drum Replacer, master the art of transient shaping, get 

the scoop on what Windows 10 means to SONAR, arrange your song ideas in the 

aŀǘǊƛȄ ±ƛŜǿΣ ŀƴŘ ŦƛƴŘ ƻǳǘ ǿƘŀǘ ƘŀǇǇŜƴǎ ǘƻ ǎƛƎƴŀƭǎ ƻƴŎŜ ǘƘŜȅΩǊŜ ƛƴǎƛŘŜ ƻŦ {hb!wΦ 
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How to Download the Jamaica Plain Update 
 

Open the Cakewalk Command Center. LŦ ȅƻǳ ŘƻƴΩǘ ƘŀǾŜ ǘƘŜ ƭŀǘŜǎǘ ƛnstaller 

(CakewalkCommandCenterSetup1.1.2.2.exe), please download it from the Cakewalk Command 

Center home page.  

 

To download the Jamaica Plain core update itself, download from the core SONAR Artist, 

Professional, or Platinum category.  

 

Professional and Platinum users should update the Engineering Suite (the LED will be yellow) to 

update Channel Tools. 

 

Platinum users should also update the Boutique Suite (the LED will be yellow) to update the VX-

64 and PX-64. 

  

https://www.cakewalk.com/Command-Center
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Patch Points   
Professional, Platinum 
 

Cakewalk has been quietly developing a Universal Routing Technology that gives tremendous 

flexibility when routing signals within SONAR. One of the first examples was the FX Chain, which 

ǇǊƻǾƛŘŜŘ ŀ άŎƻƴǘŀƛƴŜǊέ ŦƻǊ ǊƻǳǘƛƴƎ ŜŦŦŜŎǘ ƛƴǇǳǘǎ ŀƴŘ ƻǳǘǇǳǘǎ ǘƻƎŜǘƘŜǊΣ ŀƴŘ Ƙŀd the intelligence 

to disconnect controls if the effects being controlled were removed. The ProChannel and FX 

Racks are a basic ŜȄŀƳǇƭŜ ƻŦ ǘŀƪƛƴƎ ǘƘŜ άƛƴǎŜǊǘ ƧŀŎƪǎέ ƻƴ ƳƛȄŜǊǎ ǘƻ ŀ ƳƻǊŜ ŦƭŜȄƛōƭŜ ƭŜǾŜƭ ōȅ 

providing two ways of inserting effects, where one block could be pre or post compared to the 

other. 

 

Synth recording took the concept another step further by allowing real-time recording of synth 

outputs, but now Patch Points and Aux Tracks introduce a mind-boggling level of flexibility: you 

can feed tracks (audio or instrument) into tracks, buses into tracks, sends into tracks, or even 

(get ready!) tracks, sends, and buses into the same trackτand ƳǳŎƘ ƳƻǊŜΦ LǘΩǎ ŜǾŜƴ ǇƻǎǎƛōƭŜ ǘƻ 

do something like feed track outputs and bus outputs into an Aux Track, when can then feed 

with other Aux Tracks and a Send into a different track. This may sound complicated enough to 

ƳŀƪŜ ȅƻǳǊ ƘŜŀŘ ŜȄǇƭƻŘŜΣ ōǳǘ ƛǘΩǎ ŀƭƭ ƛƳǇƭŜƳŜƴǘŜŘ ƛƴ ŀ ǎƳŀǊǘ, intuitive way that not only adds 

no clutter to the Track or Console view, but even cleans up unused patch points if the routing 

changes. 

 

Please note: Projects that contain Patch Points and Aux Tracks cannot be opened in SONAR 

versions prior to SONAR Jamaica Plain (Update 9). If you need to open a project in an earlier 

version, first back up the project, unassign any patch points, then re-save the project. 

 

For detailed Patch Points information, see the New Features section in {hb!wΩǎ online Help. 

 

 

CREATING, CHOOSING, AND ASSIGNING PATCH POINTS 

 

When you open a track input or output picker, or a send or bǳǎ ƻǳǘǇǳǘ ǇƛŎƪŜǊΣ ȅƻǳΩƭƭ see the 

ƻǇǘƛƻƴ άbŜǿ tŀǘŎƘ tƻƛƴǘΦέ {ŜƭŜŎǘ ǘƘƛǎ ǘƻ ŎǊŜŀǘŜ ŀ tŀǘŎƘ tƻƛƴǘΦ This is also how you pick an 

existing Patch Point. Creating a Patch Point assigns a number that increments with each new 

Patch Point, but you can rename this (as described later). LŦ ŀ ǘǊŀŎƪΩǎ ƛƴǇǳǘ ƛǎ ŀ tŀǘŎƘ tƻƛƴǘΣ ǘƘŜ 

track icon changes to ŀ ŘƛǎǘƛƴŎǘƛǾŜ άtŀǘŎƘ tƻƛƴǘ in useέ ƛŎƻƴ. 
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Example 1: Yƻǳ ǿŀƴǘ ǘƻ ǇŀǘŎƘ ¢ǊŀŎƪ мΩǎ ƻǳǘǇǳǘ ǘƻ ¢ǊŀŎƪ нΩǎ ƛƴǇǳǘΦ {ŜƭŜŎǘ άbŜǿ tŀǘŎƘ tƻƛƴǘέ ŦƻǊ 

¢ǊŀŎƪ мΩǎ ƻǳǘǇǳǘ to create tŀǘŎƘ tƻƛƴǘ мΦ bƻǿ ŦƻǊ ¢ǊŀŎƪ нΩǎ ƛƴǇǳǘΣ ǎŜƭŜŎǘ tŀǘŎƘ tƻƛƴǘ мΦ ¢ǊŀŎƪ мΩǎ 

output now patches ǘƻ ¢ǊŀŎƪ нΩǎ ƛƴǇǳǘΦ 

 

Example 2: You want to patch ¢ǊŀŎƪ мΩǎ ƻǳǘǇǳǘ and the output from a send in Track 6 to Tracks 

2, 3, and 11. Follow the example above, but additionally, choose Patch Point 1 for the inputs to 

Tracks 3 and 11, and re-assign the send in Track 6 to Patch Point 1.  

 

You can create new Patch Points from any input or output picker. Patch Points are not 

necessarily associated with the track or ōǳǎ ǿƘŜǊŜ ǘƘŜȅ ǿŜǊŜ ŎǊŜŀǘŜŘΤ ƭƛƪŜ ŀƴ ŀǳŘƛƻ ƛƴǘŜǊŦŀŎŜΩǎ 

physical input and output, any track can pick any available Patch Point as an input, and any 

track, bus, or send can pick any available Patch Point as an output. The only significant 

restriction is that SONAR will not allow creating a feedback loop. 

 

PATCH POINT SIGNAL FLOW CHART 

 

IŜǊŜΩǎ ŀ ƎǊŀǇƘƛŎŀƭ ǊŜǇǊŜǎŜƴǘŀǘƛƻƴ ƻŦ Ƙƻǿ ŀ ǊŜǇǊŜǎŜƴǘŀǘƛǾŜ tŀǘŎƘ tƻƛƴǘ ŎƻƴƴŜŎǘƛƻƴ ƳƛƎƘǘ ǿƻǊƪΦ 

 

 
On the left, output sources (tracks, buses, and sends) all terminate in the same Patch Point. On 

the right, the Patch Point output can connect to audio and Aux Track inputs. All routing and 

submixing is handled transparently in the background. Multiple outputs can connect to a single 

input, and a single output can connect to multiple inputs. 

 

RENAMING PATCH POINTS 

 

To ǊŜƴŀƳŜ ŀ tŀǘŎƘ tƻƛƴǘΣ Ŧƻƭƭƻǿ ǘƘŜ ƛƴǇǳǘ ǇƛŎƪŜǊΩǎ tŀǘŎƘ tƻƛƴǘΩǎ ǎŜƭŜŎǘƛƻƴ ƳŜƴǳ ŀƴŘ ŎƘƻƻǎŜ 

Rename patch point. The Patch Point does not need to be the selected patch point in order to 

be renamed. Patch Points cannot be renamed from the output picker. 
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PATCH POINT HANDLING 

 

¶ ²ƘŜƴ ƴƻ ƛƴǇǳǘ ƻǊ ƻǳǘǇǳǘ ŎƻƴƴŜŎǘǎ ǘƻ ŀ tŀǘŎƘ tƻƛƴǘΣ ƛǘΩǎ ŎƻƴǎƛŘŜǊŜŘ ǳƴǳǎŜŘ ŀƴŘ {hb!w 

automatically recycles it dynamically to make your projects less complicated. 

¶ Deleting a track will not remove associated Patch Points, so that undo and redo can 

work. However, loading a project removes any unused patch points. 

¶ SONAR prevents assigning Patch Points that could cause a feedback loop. 

¶ Assigning a Patch Point to a track input automatically enables Input Echo. Selecting 

άbƻƴŜέ ŦƻǊ ǘƘŜ ƛƴǇǳǘ ǘǳǊƴǎ ƻŦŦ LƴǇǳǘ 9ŎƘƻΦ 

¶ Disconnecting all inputs and outputs to a Patch Point hides the Patch Point to prevent 

clutter, but unused Patch Points are not deleted until you save, close, and re-open the 

project. That way, they remain available for undo/redo. 

¶ Patch Point and Aux Track creation can be Quick Grouped. 
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Aux Track   
Professional, Platinum 
 

The Aux Track is a new track type ǘƘŀǘΩǎ ŀ ƎǊŜŀǘ ŎƻƳǇƭŜƳŜƴǘ ǘƻ tŀǘŎƘ tƻƛƴǘǎΦ LǘΩǎ ǎƛƳǇƭȅ ŀƴ 

audio track with its input assigned to a Patch Point, so you can specify the Aux Track as a Patch 

Point, then feed multiple tracks, buses, or combinations of tracks or buses into it. This makes 

the Aux Track an ideal destination for summing, submixing, organizing, and controlling multiple 

tracks. You can also think of an Aux Track as a bus that can live with other tracks and be 

included in a Track Folder. ̧ ƻǳ ŀŘŘ ŀƴ !ǳȄ ¢ǊŀŎƪ Ƨǳǎǘ ƭƛƪŜ ȅƻǳΩŘ ŀŘŘ ŀ tŀǘŎƘ tƻƛƴǘτby selecting 

Ǿƛŀ ŀ ǘǊŀŎƪ ƻǊ ōǳǎΩǎ ƻǳǘǇǳǘ ƳŜƴǳΦ 

 

  
 

The Aux Track now appears like a Patch Point in output menus. 
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AUX TRACK TIPS  

 

¶ If you rename the Aux Track, the name of the output of any track feeding into it updates 

automatically to reflect the change. 

¶ An Aux Track can go to any available destination including another Aux Track, a 

sidechain input, etc. 

¶ The Aux Track input can be an output generated within SONAR, like a virtual instrument 

output or another Aux Track. You can also create a new Patch Point ŦǊƻƳ ǘƘŜ !ǳȄ ¢ǊŀŎƪΩǎ 

input field. 

¶ Aux Tracks are audio tracks, with the only difference being that they have a Patch Point 

input. As a result they behave like other tracks with respect to automation, inserting 

effects, etc. 

¶ To monitor ǿƘŀǘΩǎ ƎƻƛƴƎ ƛƴǘƻ ŀƴ Aux Track, you need to enable Input Echo. 

¶ ¢ƻ ǊŜŎƻǊŘ ǿƘŀǘΩǎ ƎƻƛƴƎ ƛƴǘƻ ǘƘŜ !ǳȄ ¢ǊŀŎƪΣ ŜƴŀōƭŜ ƛǘǎ wŜŎƻǊŘ ōǳǘǘƻƴ ŀƴŘ ƛƴƛǘƛŀǘŜ 

recording. 
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Patch Point and Aux Track Applications   
Professional, Platinum 

 

Here are some representative applications for using Patch Points and Aux Tracks. There are 

often several ways to accomplish the same functionality, so use whichever is most comfortable. 

CƻǊ ŜȄŀƳǇƭŜΣ ƛŦ ȅƻǳ ŀƭǊŜŀŘȅ ƘŀǾŜ ŜȄƛǎǘƛƴƎ ǘǊŀŎƪǎ ǘƘŀǘ ȅƻǳ ǿŀƴǘ ǘƻ ŎƻƴƴŜŎǘ ǘƻ tŀǘŎƘ tƻƛƴǘǎΣ ƛǘΩǎ 

probably easier to assign their inputs to Patch Points than create new Aux Tracks. However, if 

ȅƻǳΩǊŜ ǎŜǘǘƛƴƎ ǳǇ ŀ ƴŜǿ ǊŜŎƻǊŘƛƴƎ ǎŎŜƴŀǊƛƻΣ ƛǘ ǿƛƭƭ ǇǊƻōŀōƭȅ ōŜ ŜŀǎƛŜǎǘ ǘƻ ŎǊŜŀǘŜ ŀƴ !ǳȄ ¢ǊŀŎƪ ŀǎ 

that will create both a track and a Patch Point assignment. 

 

APPLICATION #1: RECORDING THE METRONOME TO A TRACK 

 

Note: If your project already contains a Metronome bus, skip to step 7. 

 

1. Choose Insert > Stereo Bus to create a new bus for the audio metronome. 

2. Rename the new bus to Metronome. 

3. Choose Edit > Preferences > Project - Metronome. 

4. Select the Recording check box and clear the Playback check box (you will hear the 

recorded metronome instead during playback). 

5. Select άUse Audio Metronome.έ 

6. Click the Output drop-down menu and select the bus named Metronome, then click OK 

to close the Preferences dialog box. 

7. /ƭƛŎƪ ǘƘŜ aŜǘǊƻƴƻƳŜ ōǳǎΩs Output control and select New Aux Track on the pop-up 

menu. 

8. Arm the Aux Track for recording. 

9. Begin recording. 

 

APPLICATION #2: TRACK/BUS/SEND-TO-TRACK RECORDING WITH PATCH POINTS 

 

1. Assign the source track, bus, or send output to a Patch Point.  

2. Assign the destination track input to the same Patch  

Point.  

3. Record-enable the destination track. Input Echo can be on or off. 

4. Initiate recording. 

 

APPLICATION #3: TRACK/BUS/SEND-TO-TRACK RECORDING WITH AUX TRACK 

 

1. Assign the source track, bus, or send output to An Aux Track.  

2. Record-enable the Aux Track. Input Echo can be on or off. 

3. Initiate recording. 



11 | P a g e 
 

 

APPLICATION #4: MULTIPLE TRACKS/BUSES/SENDS TO SINGLE TRACK RECORDING 

 

1. Assign the source track/bus/sends outputs to an Aux Track. You can use any 

combination of tracks, buses, and sends. Note: You may need to adjust output levels 

when combining multiple outputs to avoid overloading the Aux Track. 

2. Record-enable the Aux Track. Input Echo can be on or off. 

3. Initiate recording. 

 

APPLICATION #5: MULTIBAND PROCESSING 

 

¢ƘŜǊŜ ŀǊŜ Ƴŀƴȅ ǇƻǎǎƛōƭŜ ŀǇǇƭƛŎŀǘƛƻƴǎΤ ƘŜǊŜΩǎ ŀ ǘȅǇƛŎŀƭ ǳǎŜ involving multiband distortion.  

 

 
 

A guitar feeds four tracks, each with a Sonitus:fx Multiband compressor. Each Multiband 

compressor has a different band soloed to divide the guitar into four frequency bands, with 

each band distorted via the TH2 amp sim (the reason for distorting each band individually is 

lower intermodulation distortion ŀƴŘ ŀ άŎƭŜŀƴŜǊέ distortion sound). The outputs then terminate 

in an Aux Track, which mixes all four tracks without having to set up sends. Furthermore, all the 

tracks can be processed simultaneouslȅ ǳǎƛƴƎ ǘƘŜ !ǳȄ ¢ǊŀŎƪΩǎ C· wŀŎƪΣ ŀƴŘ ǇƭŀŎŜŘ ǿƛǘƘƛƴ ŀ ¢ǊŀŎƪ 

Folder to tidy up the Track View layout. 
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APPLICATION #6: BUSLESS PARALLEL PROCESSING 

 

Parallel processing usually involves either copying a track or using a bus. The Aux Track and 

Patch Point functionality simplifies this process, and allows inclusion within a Track folder.  

 

The following example shows applying parallel compression to percussion. 

 

 
 

The main Percussion track output terminates in the Master bus, but it also includes a Send. The 

send patches to an Aux Track, which includes the parallel processor (Blue Tubes FA770). The 

Aux Track also terminates in the Master bus, thus providing the parallel path. 

 

ADDITIONAL APPLICATIONS 

 

¶ You can work exclusively in Track View, and have folders of tracks with their Aux Tracks 

adjacent to them. This workflow provides an alternative to routing tracks to buses. 

¶ Treat the Aux Track as a subgroup, and control multiple audio track volumes with one 

fader. 

¶ /ƻƴǘǊƻƭ ǎǳǊŦŀŎŜǎ ǘƘŀǘ ŘƻƴΩǘ ǎǳǇǇƻǊǘ buses can instead control Aux Tracks. 

¶ wŜŎƻǊŘ ƻƴƭȅ ŀ ǘǊŀŎƪΩǎ ŜŦŦŜŎǘǎ ǎŜƴŘ ǘƻ ŀ ǎŜǇŀǊŀǘŜ ǘǊŀŎƪΦ CƻǊ ŜȄŀƳǇƭŜΣ ȅƻǳ Ŏŀƴ ǊŜŎƻǊŘ ŀ 

delay effect to a separate track, and shift the timing as desired. 

¶ Capture real-time performances with guitar effects, including amp sims. 

¶ Record time-based effects in real time. 

¶ Record plug-in parameter changes that are not automatable. 
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Start Screen Enhancements   
Artist, Professional, Platinum 

 

 
 

The Start Screen Ƙŀǎ ǎƻƳŜ ƳŀƧƻǊ ƛƳǇǊƻǾŜƳŜƴǘǎ ǘƘŀǘ ǿƛƭƭ ƎŜǘ ȅƻǳ ƻŦŦ ǘƻ ŀ ōŜǘǘŜǊΧǎǘŀǊǘΦ 

 

¶ The Start Screen now appears immediately after SONAR has loaded, or you select Start 

Screen from the File menu.  

¶ If you close a project, the Start Screen does not re-appear automatically (although you 

can always select it from the File Menu). 

¶ Several language incompatibilities have been addressed. 

¶ Clicking on the File menu closes the Start Screen if present. 

¶ The Default Template now moves to the top of the list. 
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Upsample on Playback    
Artist, Professional, Platinum 

 

Some plug-ins and virtual instruments sound better when recording at sample rates higher than 

44.1/48 kHz because high audio frequencies can interfere with lower clock frequencies, which 

causes foldover distortion. ¢Ƙƛǎ ŀŘŘǎ ŀ άǿƻƻƭƛƴŜǎǎέ at lower frequencies, and can also 

compromise high-frequency response. Plug-ins that include internal oversampling do not have 

this problem, but not all plug-insτparticularly older onesτuse oversampling. 

 

The Foxboro update introduced Upsample on Render, which provides the benefits of using 

higher sample rate processing even in 44.1 kHz or 48 kHz projects by internally 2X up-sampling 

plug-ins of your choice, rendering them as audio, then down-sampling the rendered audio back 

down to the original sample rate. While it may seem counter-intuitive that the audio quality 

from rendering at 96 kHz is preserved at lower sample rates, the lower sample rates have no 

problem reproducing signals in the audio range, and by rendering at 96 kHz, the problematic 

frequencies no longer exist. 

 

The Jamaica Plain update now offers Upsample on Playback, so you can preview and compare 

the difference in real time. To enable either Upsampling on Render or Upsampling on Playback 

on a per-plug-in basis, click the FX button to the left of the instrument name in the virtual 

instrument interface.  

 

 
 

To turn Upsampling on or off globally for plug-ins that have upsampling enabled, use the 2X 

ōǳǘǘƻƴ ƛƴ ǘƘŜ /ƻƴǘǊƻƭ .ŀǊΩǎ aƛȄ ƳƻŘǳƭŜΦ 
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Performance and Engine Optimizations   
Artist, Professional, Platinum 
 

In addition to implementing new features, we continue to probe existing elements within 

{hb!w ŦƻǊ ǇƻǘŜƴǘƛŀƭ ƛƳǇǊƻǾŜƳŜƴǘǎΦ ¢ƘŜ WŀƳŀƛŎŀ tƭŀƛƴ ǳǇŘŀǘŜ ƛǎ ǘƘŜ ŎǳƭƳƛƴŀǘƛƻƴ ƻŦ ǿƻǊƪ ǘƘŀǘΩǎ 

ōŜŜƴ ƎƻƛƴƎ ƻƴ άōŜƘƛƴŘ ǘƘŜ ǎŎŜƴŜǎέ ǘƻ ƳŀƪŜ ǘƘŜ ƭŀǘŜǎǘ ǾŜǊǎƛƻƴ ƻŦ {hb!w ǘƘŜ ŦŀǎǘŜǎǘ ŀƴŘ 

smoothest yet.  

 

DYNAMIC SILENT SYNTH OUTPUT CPU SAVER 

 

SONAR detects silence on VST2 and VST3 synth outputs, and dynamically activates the output 

for input monitoring/mixing/recording only when a synth output is not silent. For projects or 

templates containing hundreds of synth tracks, the CPU savings can be significant. (Note that 

although VST3 supports turning off plug-ins when silent, hardly any instruments implement 

ǘƘƛǎΦ CƻǊǘǳƴŀǘŜƭȅΣ {hb!wΩǎ ōǳƛƭǘ-in output CPU saver provides the same results.) 

 

DYNAMIC ARM DURING PLAYBACK/RECORD 

 

Dynamic Arm for inputs now performs record pre-roll only for inputs actually present in the 

project, resulting in more responsive transport startup and stop when pressing play (especially 

for projects with synth inputs). This option also skips processing for archived tracks, saving 

additional CPU consumption. 

 

EXCLUDE SYNTH INPUTS FROM ALLOW ARM CHANGES  

 

 
 

In Preferences > Project > Record, checking the boxes ǳƴŘŜǊ ά!ƭƭƻǿ !ǊƳ /ƘŀƴƎŜǎέ όthey default 

to checked) improves transport performance on start and stop with large projects containing 
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hundreds of synth tracks. When checked, you can arm tracks only when the transport is 

stopped. This avoids record pre-roll overhead caused by needing to pre-create record files for 

synth inputs. 

 

SYNTH STREAMING CPU MULTIPROCESSING 

 

For maximum efficiency with projects containing many virtual instrument tracks, the synth 

streaming code streamlines multiprocessing to reduce CPU load on synth track playback. 

 

GENERAL PRE-ROLL IMPROVEMENTS 

 

The pre-roll code improves transport startup by identifying and ignoring unneeded startup 

tasks. 

 

IMPROVED PROJECT LOAD SPEED  

 

The project load code now prevents unnecessary engine start/stop transitions, so loading 

projects containing hundreds of tracks is now orders of magnitude faster.  

 

VST SCANNING OPTIMIZATIONS AND ENHANCEMENTS 

 

¶ {ŎŀƴƴƛƴƎ ƛǎ ŦŀǎǘŜǊ ŦƻǊ άǎƘŜƭƭέ ǇƭǳƎ-ins that contain many sub plug-ins (e.g., Waves). 

¶ With plug-in suites where the number of available VST2 or VST3 plug-ins can change 

dynamically, SONAR automatically removes de-activated plug-ins from the inventory 

and adds them back if re-activated.  

¶ LǘΩǎ ƴƻ ƭƻƴƎŜǊ ƴŜŎŜǎǎŀǊȅ ǘƻ ǊŜǎŜǘ ǘƘŜ ±{¢ ƛƴǾŜƴǘƻǊȅ ǘƻ ǎŜŜ ǇƭǳƎ-ins that previously were 

not scanned successfully.  

¶ Unauthorized plug-ins no longer appear ƛƴ {hb!wΩǎ ǳǎŜǊ ƛƴǘŜǊŦŀŎŜΦ 
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Fixes and Workflow Enhancements 
Artist, Professional, Platinum 

 

Fixed issues where: 

 

¶ MIDI inputs did not work correctly when Quick Grouped  

¶ Dragging clips with a large snap offset would not work properly 

¶ Sends on Instrument tracks would not respect follow track pan 

¶ Focus would switch to the Track View from Event List when using the "Kind of Event" 

dialog 

¶ Now time would not adjust on the time line when clicked more than once   

¶ Multiple LP-64 plug-ins could cause playback and rendering issues under some 

conditions 

¶ MIDI record confidence recording preview would not work under certain conditions 

¶ Event List had display problems with 25 characters or more 

¶ Shelf graphics were reversed in EQ 

¶ Pasting a composite clip to a new track could cause a hang 

¶ Fit MIDI Content in PRV and inline PRV was inconsistent 

¶ 3rd party ProChannel plug-ins would not display correctly when tracks were cloned 

¶ Drag and drop to the Browser could create a problem with a folder created in Windows 

¶ VX-64 Vocal Strip plug-in (Boutique Suite) could cause audio output issues in projects 

¶ Quickly freezing multiple tracks with Drum Replacer could crash 

¶ Export to DSD could crash on AMD systems 

¶ Channel Tools plug-in (Engineering Suite) could cause audio output problems 

¶ Track and folder names ŘƛŘƴΩǘ work correctly with synth replace 

¶ Sonar font sizes would shrink when adding TruePianos VSTi 

¶ Opening projects without saving was not populating the Start Screen correctly  

¶ Start screen was not displaying some characters correctly, causing projects not to open 

upon sign-on in Windows 7 OS 

¶ Staff View had snapping problems when adding notes  

¶ Launching projects from the desktop was not enabling the audio engine 

¶ Start screen behavior was not optimized when accessing menus 

¶ Delete key and right-click smart tool delete were not working in PRV Drum pane view 

¶ Templates were not saving audio correctly 

¶ Recording synths from mono inputs was not working 

¶ Browser did not support .png graphics format 

¶ Linked Melodyne clips were not rendering properly, thus causing silence 

¶ SONAR could crash when deleting a REX loop while open in Loop Construction view 

¶ Eiosis plug-ins would not scan properly after update 
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¶ Certain files and templates could take a long time to load 

¶ Clicking on some controls caused unnecessarily άdirtyέ documents 

¶ Control Bar Performance module was not updating properly when disabling 

Multiprocessing Engine 

¶ IƻǊƛȊƻƴǘŀƭ ƳƻǳǎŜ ǎŎǊƻƭƭƛƴƎ ŘƛŘƴΩǘ ǿƻǊƪ ǿƛǘƘ ƳƻǳǎŜ ƘŀǊŘǿŀǊŜ ǘƘŀǘ ǎǳǇǇƻrted horizontal 

mouse scrolling  
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Review: Electronic Dance Music Grooves 
Hal Leonard Books 

Softcover, 263 pages, $17.48 

 

By Craig Anderton 

 

hƪŀȅΣ ǎƻ ǿƘŀǘΩǎ ŀ ōƻƻƪ ǿǊƛǘǘŜƴ ōȅ Josh Bess, an Ableton 

Certified Trainer, doing in here? Simple: the book is just 

as applicable to SONARτand maybe even more so given 

{hb!wΩǎ inclusion of a Step Sequencer along with the 

MIDI Piano Roll View. 

 

You can skip the first chapter, which describes Live 

basics. The second has useful concepts for beginners 

that translate to SONAR, but the meat of the bookτ170 

pagesτis Chapter 3, which shows screen shots for 

grooves. Musical styles include house, techno, 

breakbeat (e.g., hip-ƘƛǇΣ ŘǊǳƳ ΨƴΩ ōŀǎǎύ, and world (e.g., 

dance hall), along with several sub-genres for each. 

 

Although beats are ǎƘƻǿƴ ǳǎƛƴƎ [ƛǾŜΩǎ tƛŀƴƻ wƻƭƭ ±ƛŜǿΣ 

ƛǘΩǎ Ŝŀǎȅ ǘƻ ǘǊŀƴǎƭŀǘŜ ǘƻ {hb!wΩǎ tw± ƻǊ {ǘŜǇ {Ŝǉǳencer. Each pattern also includes info about 

some of the techniques used in the pattern, as well as occasional tips. 

 

Chapter 4 is 14 pages about drum fills and 

transitions, again using screen shots for 

examples, while Chapter 5 covers Groove, 

Swing, and Feel. This takes only slightly more 

ŜŦŦƻǊǘ ǘƻ ǘǊŀƴǎƭŀǘŜ ƛƴǘƻ {hb!wΩǎ ŜǉǳƛǾŀƭŜƴǘǎΦ 

Chapter 6 has 22 pages of how to build drum 

kits in Live from one-shots, and Chapter 7 is a 

one-page summary.  

 

The book also includes a code for downloading 

a variety of media. For SONAR users, the items 

of greatest interest are the 292 drum samples 

(mostly WAV, some AIF, both of which are easy 

to load into Session Drummer to create your 

own kits), along with the 642 MIDI files for 

grooves and the 19 MIDI files for fills.  


